アップグレードガイド

KARTE SDK のアップグレードを行う際は、基本的に全てのパッケージを最新化することを推奨しております。

下記コマンドでアップグレードが可能です。

# パッケージをアップデート
npm update @react-native-karte/core

# 必要に応じて core 以外のパッケージもアップデートしてください
# npm update @react-native-karte/in-app-messaging
# npm update @react-native-karte/notification
# npm update @react-native-karte/variables

# Pod をインストール
npx pod-install ios

なおネイティブSDKのみアップグレードを行いたい場合は、下記コマンドを実行してください。

# 全ての依存ライブラリ(KARTE SDK以外も含む)を更新
pod update

# KARTE SDKのみを更新
pod update RNKRTCore RNKRTInAppMessaging RNKRTNotification RNKRTVariables

📘

アップグレードガイドの記載について

アップグレードに際し、特別な対応が必要となるバージョンのみ記載し、それ以外のバージョンについては記載を省略しています。

notification

0.2.0 へのアップグレード

パッケージのアップデートに加え、ネイティブSDKのアップグレードを行う必要があります。